great bit of sleuthing. Right I will specify the exact interfaces! I think it is a definite feature request

On Wed, 24 Jul 2019 at 15:36, Andy Smith <> wrote:

On Wed, Jul 24, 2019 at 12:43:58PM +0000, Andy Smith wrote:
> Is this normal? I am used to daemons giving up when they can't
> exclusively bind.

I tried making one of my own bind9 servers start while something
else was bound to IP:53, and it also worked, but it did complain:

Jul 24 13:14:13 authns0 named[10713]: listening on IPv4 interface eth0:0,
Jul 24 13:14:13 authns0 named[10713]: binding TCP socket: address in use

Keith's doesn't even complain.

I've worked out why.

The default configuration of bind9 is to bind to all v4 and v6
addresses on the system. In that mode, if it can't bind to one then
it silently fails.

If you configure it to only bind to specific interfaces (as I do),
then it complains when it can't.

I am unhappy that it only complains. I'd like it to refuse to start
entirely, such that systemd notices. I would be interested to know
if that can be done or if it would be a feature request.


-- -- No-nonsense VPS hosting
users mailing list